CVE-2025-59302
ŚrednieCVSS 4.7Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 38 - wyżej niż 38% wszystkich znanych CVE
Streszczenie
W Apache CloudStack występuje podatność typu code injection w API dostępnych wyłącznie dla administratorów: quotaTariffCreate, quotaTariffUpdate, createSecondaryStorageSelector, updateSecondaryStorageSelector, updateHost i updateStorage. Problem dotyczy wersji od 4.18.0 przed 4.20.2 oraz od 4.21.0 przed 4.22.0.
Ocena ryzyka
Administrator może wstrzyknąć kod, co może prowadzić do wykonania nieautoryzowanych operacji w systemie. Ryzyko jest ograniczone do kont administracyjnych, ale może skutkować poważnym naruszeniem bezpieczeństwa.
Rekomendacja
Zaktualizuj Apache CloudStack do wersji 4.20.2 lub 4.22.0. Rozważ ustawienie flagi js.interpretation.enabled w celu kontroli interpretacji wyrażeń JavaScript w tych API.
Inne podatności w Apache CloudStack
Zobacz wszystkie- CVE-2026-62440Krytyczne
Podatność na niewłaściwą kontrolę dostępu w Apache CloudStack wtyczki Kubernetes Service (CKS), umożliwiająca manipulację klastrem Kubernetes między dzierżawcami podczas dodawania i usuwania węzłów. Dotyczy wersji od 4.21.0.0 do 4.22.1.0.
- CVE-2026-61398Krytyczne
Podatność na niewłaściwe kodowanie lub escapowanie danych wyjściowych w interfejsie użytkownika Apache CloudStack podczas korzystania z funkcji resetowania hasła instancji. Dotyczy wersji od 4.15.1.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0.
- CVE-2026-59085Krytyczne
Podatność typu Server-Side Request Forgery (SSRF) w module webhook Apache CloudStack, możliwa do wykorzystania przez żądania dostarczania webhooków. Problem dotyczy wersji od 4.20.0.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0.
- CVE-2026-25199Krytyczne
W rozszerzeniu Proxmox dla Apache CloudStack użytkownik bez uprawnień może zmodyfikować pole proxmox_vmid, aby wskazać maszynę wirtualną należącą do innego tenanta. Pozwala to na nieautoryzowany dostęp międzydzierżawczy i pełną kontrolę nad docelową maszyną, w tym jej uruchamianie, zatrzymywanie i niszczenie.
- CVE-2015-3252Krytyczne
Apache CloudStack przed wersją 4.5.2 nieprawidłowo zachowuje hasła VNC podczas migracji maszyn wirtualnych KVM, co umożliwia zdalnym atakującym uzyskanie dostępu poprzez połączenie z serwerem VNC.
- CVE-2026-59654Wysokie
Apache CloudStack w wersjach od 4.7.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0 zawiera podatność na brak zwolnienia zasobów po ich użyciu w funkcji globalnej konfiguracji zakresowej. Może to prowadzić do odmowy usługi (DoS) serwera zarządzania CloudStack.
- CVE-2026-68745Wysokie
Błędy walidacji certyfikatów w uwierzytelnianiu SAML w Apache CloudStack 4.20.3.0 i 4.22.1.0 pozwalają złośliwemu agentowi na sfałszowanie odpowiedzi SAML do serwera zarządzania. Agent musi podszyć adres IP IdP lub zarejestrować własny URL w serwerze zarządzania, po czym może umożliwić logowanie z fałszywymi podpisami. Zalecane jest uaktualnienie do wersji 4.20.3.1 lub 4.22.1.1 i nowszych.
- CVE-2026-66797Średnie
Niewłaściwa kontrola dostępu w funkcji adnotacji w CloudStack umożliwia nieautoryzowane tworzenie komentarzy i ujawnianie istniejących. API addAnnotation i listAnnotation wykonują kontrolę własności, ale nie honorują jej wyniku poprawnie, co pozwala każdemu uwierzytelnionemu użytkownikowi na zapis i odczyt adnotacji na encjach, których nie posiada. Problem dotyczy wersji od 4.15.0.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0.
- CVE-2026-66722Wysokie
Niewłaściwa autoryzacja dla operacji CRUD na rolach projektów i uprawnieniach ról projektów dla administratorów domen w CloudStack. Administrator domeny może tworzyć, aktualizować, usuwać i listować role projektów oraz uprawnienia dla projektów w dowolnej domenie, nie tylko własnej. Problem dotyczy wersji od 4.15.0.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0.
- CVE-2026-66721Niskie
Brak autoryzacji dla administratorów domen w funkcji listowania tagów hostów w CloudStack. Administratorzy domen mają domyślnie uprawnienia do wywoływania API listHostTags, ale API zwraca tagi hostów dla wszystkich hostów w środowisku bez ograniczenia do domeny. Problem dotyczy wersji od 4.12.0.0 do 4.20.3.0 oraz od 4.21.0.0 do 4.22.1.0.
Oryginalny opis (angielski, źródło NVD)
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

