Katalog CVE

CVE-2025-46817

WysokieCVSS 7.0
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Wysokie ryzyko
3.83%

Percentyl 90 - wyżej niż 90% wszystkich znanych CVE

Streszczenie

Redis w wersjach 8.2.1 i starszych pozwala uwierzytelnionemu użytkownikowi na użycie specjalnie spreparowanego skryptu Lua, co powoduje przepełnienie liczby całkowitej i potencjalnie prowadzi do zdalnego wykonania kodu. Problem występuje we wszystkich wersjach Redis z obsługą skryptów Lua. Został naprawiony w wersji 8.2.2.

Ocena ryzyka

Uwierzytelniony atakujący może wykorzystać tę podatność do wykonania dowolnego kodu na serwerze Redis, co może prowadzić do pełnego przejęcia systemu i dostępu do przechowywanych danych.

Rekomendacja

Zaktualizuj Redis do wersji 8.2.2 lub nowszej. Ogranicz dostęp do serwera Redis i stosuj silne uwierzytelnianie.

Inne podatności w Redis

Zobacz wszystkie
Oryginalny opis (angielski, źródło NVD)

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS