CVE-2024-53677
KrytyczneCVSS 9.8Prawdopodobieństwo exploitacji (EPSS)
Bardzo wysokie ryzykoPercentyl 99 - wyżej niż 99% wszystkich znanych CVE
Streszczenie
Logika przesyłania plików w Apache Struts jest wadliwa. Atakujący może manipulować parametrami przesyłania plików, aby umożliwić path traversal, co w niektórych przypadkach może prowadzić do przesłania złośliwego pliku i zdalnego wykonania kodu. Problem dotyczy Apache Struts od wersji 2.0.0 przed 6.4.0.
Ocena ryzyka
Atakujący może zdalnie wykonać dowolny kod na serwerze aplikacji, co prowadzi do pełnego przejęcia systemu i naruszenia poufności, integralności i dostępności.
Rekomendacja
Zaktualizować Apache Struts do wersji co najmniej 6.4.0 i zmigrować do nowego mechanizmu przesyłania plików. Jeśli aplikacja nie używa starej logiki opartej na FileuploadInterceptor, jest bezpieczna.
Inne podatności w Apache Struts
Zobacz wszystkie- CVE-2016-3090Wysokie
Metoda TextParseUtil.translateVariables w Apache Struts 2.x przed wersją 2.3.20 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez spreparowane wyrażenie OGNL z wykorzystaniem narzędzi ANTLR.
- CVE-2016-4461Wysokie
Apache Struts 2.x przed wersją 2.3.29 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez sekwencję "%{}" w atrybucie tagu, co jest znane jako wymuszone podwójne ocenianie OGNL.
- CVE-2017-9804Wysokie
W Apache Struts w wersjach od 2.3.7 do 2.3.33 oraz od 2.5 do 2.5.12, istnieje możliwość przygotowania specjalnego URL, który może przeciążyć proces serwera podczas walidacji URL w formularzu. Problem ten wynika z niekompletnej poprawki dla S2-047 / CVE-2017-7672.
- CVE-2015-5209Wysokie
Apache Struts 2.x przed wersją 2.3.24.1 pozwala zdalnym atakującym na manipulację wewnętrznymi elementami Struts, co może prowadzić do zmiany sesji użytkowników lub wpływania na ustawienia kontenera.
- CVE-2017-9787Wysokie
Wykorzystanie funkcjonalności AOP w Spring do zabezpieczania akcji Struts może prowadzić do ataku DoS.
- CVE-2016-4433Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 pozwala zdalnym atakującym na obejście zamierzonych ograniczeń dostępu oraz przeprowadzenie ataków redirekcyjnych za pomocą spreparowanego żądania.
- CVE-2016-4431Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 pozwala zdalnym atakującym na obejście zamierzonych ograniczeń dostępu oraz przeprowadzanie ataków redirekcyjnych poprzez wykorzystanie domyślnej metody.
- CVE-2016-4430Wysokie
Apache Struts 2 w wersjach od 2.3.20 do 2.3.28.1 niewłaściwie obsługuje walidację tokenów, co umożliwia zdalnym atakującym przeprowadzanie ataków typu cross-site request forgery (CSRF) za pomocą nieokreślonych wektorów.
- CVE-2016-0785Wysokie
Apache Struts 2.x przed wersją 2.3.28 umożliwia zdalnym atakującym wykonanie dowolnego kodu poprzez sekwencję "%{}" w atrybucie tagu, co jest znane jako wymuszone podwójne ocenianie OGNL.
- CVE-2015-1831Wysokie
Domyślne wzorce wykluczeń (excludeParams) w Apache Struts 2.3.20 umożliwiają zdalnym atakującym kompromitację wewnętrznego stanu aplikacji za pomocą nieokreślonych wektorów.
Oryginalny opis (angielski, źródło NVD)
File upload logic in Apache Struts is flawed. An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. This issue affects Apache Struts: from 2.0.0 before 6.4.0. Users are recommended to upgrade to version 6.4.0 at least and migrate to the new file upload mechanism https://struts.apache.org/core-developers/file-upload . If you are not using an old file upload logic based on FileuploadInterceptor your application is safe. You can find more details in https://cwiki.apache.org/confluence/display/WW/S2-067
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

