CVE-2023-3691
NiskieCVSS 3.5Prawdopodobieństwo exploitacji (EPSS)
Niskie ryzykoPercentyl 38 - wyżej niż 38% wszystkich znanych CVE
Streszczenie
Wykryto podatność w layui do wersji 2.8.0-rc.16, która dotyczy nieznanej części komponentu HTML Attribute Handler. Manipulacja argumentem title prowadzi do ataku typu cross-site scripting.
Ocena ryzyka
Atakujący może zdalnie wykorzystać tę podatność, co może prowadzić do kradzieży danych lub przejęcia sesji użytkownika.
Rekomendacja
Zaleca się aktualizację do wersji 2.8.0, aby usunąć tę podatność.
Powiązane podatności
- CVE-2026-95733Krytyczne
W komponencie HPE Networking Fabric Composer istnieje podatność, której wykorzystanie może pozwolić nieuwierzytelnionemu atakującemu z sąsiedniej sieci na wykonanie dowolnego kodu w zaatakowanym systemie.
- CVE-2026-95732Krytyczne
W systemie operacyjnym bazowym HPE Networking Fabric Composer występuje podatność pozwalająca na obejście uwierzytelniania. Jej wykorzystanie może umożliwić nieuwierzytelnionemu atakującemu z sąsiedniej sieci wykonanie dowolnego kodu w zaatakowanym systemie.
- CVE-2026-95731Krytyczne
W interfejsie wiersza poleceń HPE Networking Fabric Composer występują podatności związane z zaszytymi na stałe hasłami. Nieuwierzytelniony zdalny atakujący może użyć tych poświadczeń, aby uzyskać dostęp administracyjny z podwyższonymi uprawnieniami do zaatakowanego systemu.
- CVE-2026-63471Krytyczne
fastapi-code-generator przed wersją 0.8.1 wstawia ścieżkę OpenAPI do dekoratora trasy @app.get(...) jako ciąg w pojedynczych cudzysłowach bez escapowania osadzonych cudzysłowów. Ścieżka kontrolowana przez atakującego może zamknąć ciąg i wstrzyknąć wyrażenie Python do argumentu dekoratora. Poprawny składniowo wygenerowany kod wykonuje się z uprawnieniami aplikacji lub procesu CI przy imporcie modułu.
- CVE-2026-63470Krytyczne
fastapi-code-generator przed wersją 0.8.1 wstawia Operation.summary do docstringa wygenerowanego handlera trasy jako ciąg w potrójnych cudzysłowach bez escapowania osadzonych potrójnych cudzysłowów. Podsumowanie operacji kontrolowane przez atakującego może zamknąć docstring i wstrzyknąć instrukcję Python do ciała handlera. Poprawny składniowo kod wykonuje się z uprawnieniami procesu serwera przy wywołaniu handlera.
- CVE-2026-63469Krytyczne
fastapi-code-generator przed wersją 0.8.1 wstawia dodatkowy klucz kodu statusu odpowiedzi do słownika responses={...} dekoratora trasy jako ciąg w pojedynczych cudzysłowach bez escapowania osadzonych cudzysłowów. Klucz drugiej, niepodstawowej odpowiedzi kontrolowany przez atakującego może zamknąć literał klucza i wstrzyknąć wyrażenie Python. Poprawny składniowo kod wykonuje się z uprawnieniami aplikacji lub procesu CI przy imporcie modułu.
- CVE-2026-112917Krytyczne
W Docker Desktop dla Windows z backendem WSL2 nieuprzywilejowany kontener Linux może użyć 32-bitowego wywołania socketcall, aby obejść domyślne ograniczenie seccomp na AF_VSOCK. Może to ujawnić usługi hosta oraz pliki Windows dostępne dla zalogowanego użytkownika. Problem dotyczy x86-64 WSL2; backendy oparte na LinuxKit nie są dotknięte.
- CVE-2026-44267Krytyczne
W bibliotece Elo w wersjach przed 1.0.1 zwykłe łańcuchy znaków przekazywane do parsera mogą wykorzystać właściwość .constructor.constructor do uzyskania dostępu do obiektu JavaScript Function. Powstały kod JavaScript wykonuje kod wybrany przez atakującego w środowisku hosta, co umożliwia wykonanie skryptu w przeglądarce oraz wykonanie dowolnego kodu Node.js.
- CVE-2026-44266Krytyczne
W bibliotece Elo w wersjach przed 1.0.1 backend Ruby osadza tekst kontrolowany przez atakującego w podwójnie cytowanych łańcuchach Ruby bez escapowania znaku #. Formy interpolacji Ruby w emitterze literałów łańcuchowych lub gałęzi ograniczeń podtypów stają się wykonywalnym kodem Ruby, co umożliwia wykonanie kodu Ruby i poleceń powłoki.
- CVE-2026-28336Krytyczne
SolarWinds Dameware zawiera podatność na wstrzyknięcie poleceń, która może doprowadzić do przejęcia zdalnie kontrolowanego hosta. Wymagane jest uwierzytelnienie.
Oryginalny opis (angielski, źródło NVD)
A vulnerability, which was classified as problematic, was found in layui up to v2.8.0-rc.16. This affects an unknown part of the component HTML Attribute Handler. The manipulation of the argument title leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.8.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-234237 was assigned to this vulnerability.
Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS

