Katalog CVE

CVE-2020-11022

ŚrednieCVSS 6.9
Opublikowano: Zaktualizowano: Przetłumaczono: NVD NIST

Prawdopodobieństwo exploitacji (EPSS)

Bardzo wysokie ryzyko
99.22%

Percentyl 100 - wyżej niż 100% wszystkich znanych CVE

Streszczenie

W jQuery od wersji 1.12.0 do wersji przed 3.5.0 przekazanie HTML z niezaufanych źródeł — nawet po jego sanityzacji — do jednej z metod manipulacji DOM jQuery (np. .html(), .append() i innych) może spowodować wykonanie niezaufanego kodu. Problem naprawiono w jQuery 3.5.0.

Ocena ryzyka

Aplikacje korzystające z podatnych wersji jQuery mogą być narażone na ataki XSS, prowadzące do wykonania złośliwego kodu w przeglądarce użytkownika.

Rekomendacja

Zaktualizuj jQuery do wersji 3.5.0 lub nowszej we wszystkich aplikacjach internetowych.

Inne podatności w jQuery

Oryginalny opis (angielski, źródło NVD)

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Dane podatności pochodzą z NVD (NIST) · CISA KEV · EPSS