CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.26)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2019-14899
Low
—

Wykryto podatność w systemach Linux, FreeBSD, OpenBSD, MacOS, iOS oraz Android, która umożliwia złośliwemu punktowi dostępu lub sąsiedniemu użytkownikowi ustalenie, czy podłączony użytkownik korzysta z VPN. Atakujący może również wyciągać pozytywne wnioski na temat odwiedzanych stron internetowych oraz ustalać poprawną sekwencję i potwierdzenia.

CVE-2024-0217
Low
—

W PackageKitd wykryto lukę typu use-after-free. W pewnych warunkach kolejność mechanizmów czyszczenia dla transakcji może być zaburzona, co prowadzi do dostępu do obszarów pamięci, które zostały wcześniej zwolnione.

CVE-2018-12929
Low
—

W jądrze Linuxa w wersji 4.15.0 występuje podatność w sterowniku systemu plików ntfs, która pozwala atakującym na wywołanie odczytu po zwolnieniu pamięci (use-after-free) poprzez spreparowany system plików ntfs. Może to prowadzić do awarii systemu (kernel oops lub panic).

CVE-2026-109117
Unknown
—

No detailed description is available for CVE-2026-109117. Information about the vulnerability type, affected component, and exploitation mechanism is not provided.

CVE-2017-9937
Low
—

In LibTIFF 4.0.8, there is a memory malloc failure in tif_jbig.c. A crafted TIFF document can lead to an abort resulting in a remote denial of service attack.

CVE-2025-8961
Low
—

Wykryto słabość w LibTIFF 4.7.0, która dotyczy funkcji main w pliku tiffcrop.c komponentu tiffcrop. Manipulacja tą funkcją może prowadzić do uszkodzenia pamięci.

CVE-2026-25056
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 1.118.0 i 2.4.0, podatność w trybie zapytania SQL w węźle Merge pozwalała uwierzytelnionym użytkownikom z uprawnieniami do tworzenia lub modyfikowania procesów roboczych na zapisanie dowolnych plików w systemie plików serwera n8n.

CVE-2026-27497
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.10.1, 2.9.3 i 1.123.22, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wykorzystać tryb zapytania SQL w węźle Merge do wykonania dowolnego kodu oraz zapisu dowolnych plików na serwerze n8n.

CVE-2026-33696
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.14.1, 2.13.3 i 1.123.27, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wykorzystać podatność na zanieczyszczenie prototypu w węzłach XML i GSuiteAdmin.

CVE-2019-9543
Low
—

W Poppler 0.74.0 odkryto problem związany z rekurencyjnym wywołaniem funkcji w JBIG2Stream::readGenericBitmap(). Może to zostać wywołane przez wysłanie spreparowanego pliku PDF do binarnego programu pdfseparate, co prowadzi do awarii systemu (błąd segmentacji).

CVE-2019-6988
Low
—

W OpenJPEG 2.3.0 odkryto problem, który pozwala zdalnym atakującym na wywołanie odmowy usługi poprzez próbę nadmiernej alokacji pamięci w funkcji opj_calloc. Problem ten występuje podczas wywołania z opj_tcd_init_tile.

CVE-2014-5459
Low
—

Klasa PEAR_REST w pliku REST.php w PEAR w PHP do wersji 5.6.0 umożliwia lokalnym użytkownikom zapis do dowolnych plików poprzez atak symlink na plik (1) rest.cachefile lub (2) rest.cacheid w katalogu /tmp/pear/cache/, związane z funkcjami retrieveCacheFirst i useLocalCache.

CVE-2026-33660
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.14.1, 2.13.3 i 1.123.26, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wykorzystać tryb 'Combine by SQL' w węźle Merge do odczytu lokalnych plików na hoście n8n oraz uzyskać zdalne wykonanie kodu.

CVE-2026-33864
Critical
—

W najnowszej wersji pakietu convict npm (6.2.4) występuje podatność na zanieczyszczenie prototypu. Mimo wcześniejszej poprawki, która miała na celu ograniczenie zanieczyszczenia prototypu poprzez sprawdzanie, czy dane wejściowe użytkownika zaczynają się od zastrzeżonego klucza, nadal możliwe jest zanieczyszczenie `Object.prototype`.

CVE-2026-25053
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 1.123.10 i 2.5.0, podatności w węźle Git pozwalały uwierzytelnionym użytkownikom z uprawnieniami do tworzenia lub modyfikowania procesów roboczych na wykonywanie dowolnych poleceń systemowych lub odczytywanie dowolnych plików na hoście n8n.

CVE-2025-7783
Critical
—

Podatność związana z używaniem niewystarczająco losowych wartości w form-data umożliwia atak typu HTTP Parameter Pollution (HPP). Dotyczy to plików programowych lib/form_data.Js oraz wersji form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.

CVE-2026-25115
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersją 2.4.8 istniała podatność w węźle kodu Python, która pozwalała uwierzytelnionym użytkownikom na wydostanie się z piaskownicy Pythona i wykonanie kodu poza zamierzonymi granicami bezpieczeństwa.

CVE-2006-10002
Medium
—

A vulnerability in the XML::Parser library for Perl (up to version 2.45) causes a heap buffer overflow, leading to double free or corruption and crashes. The issue occurs in the parse_stream() function in Expat.xs when the :utf8 PerlIO layer is used, because Perl returns decoded characters while SvPV() expects raw bytes.

CVE-2005-1119
Low
—

Sudo VISudo version 1.6.8 and earlier allows local users to corrupt arbitrary files via a symlink attack on temporary files.

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS