CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.26)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2024-9681
Medium
—

When curl is asked to use HSTS, the expiry time for a subdomain might overwrite a parent domain's cache entry, making it end sooner or later than otherwise intended. This affects applications using HSTS and URLs with the insecure HTTP:// scheme.

CVE-2023-4641
Medium
—

A flaw in shadow-utils fails to properly clear the buffer when a new password is entered twice and the second attempt fails. This leaves the first password in memory, potentially allowing an attacker with sufficient access to retrieve it.

CVE-2024-50349
Medium
—

When Git asks for credentials via a terminal prompt (without using a credential helper), it prints the host name for which the credentials are requested. This may lead to unintended disclosure of the host name.

CVE-2019-14855
Low
—

A flaw in GnuPG before version 2.2.18 allows certificate signature forgery using SHA-1 collision attacks. An attacker can create forged certificate signatures, compromising authentication integrity.

DSA-6572-1
Unknown
—

No vulnerability description is available in the provided NVD data. Technical details and impact scope cannot be determined from the supplied information.

CVE-2026-27942
Low
—

fast-xml-parser przed wersją 5.3.8 powodował awarię aplikacji z powodu przepełnienia stosu, gdy użytkownik korzystał z budowniczego XML z opcją `preserveOrder:true`. Wersja 5.3.8 naprawia ten problem.

CVE-2025-61143
Low
—

W libtiff w wersjach do 4.7.1 odkryto podatność na dereferencję wskaźnika NULL w komponencie libtiff/tif_open.c. Może to prowadzić do nieoczekiwanego zachowania aplikacji.

CVE-2026-22795
Low
—

W aplikacji przetwarzającej źle sformatowany plik PKCS#12 może wystąpić dereferencja nieprawidłowego lub pustego wskaźnika. Może to prowadzić do awarii aplikacji.

CVE-2024-7042
Low
—

Podatność w klasie GraphCypherQAChain w wersjach 0.2.5 i wcześniejszych langchain-ai/langchainjs umożliwia wstrzykiwanie poleceń, co prowadzi do możliwości SQL injection. Umożliwia to nieautoryzowaną manipulację danymi oraz ich wyciek.

CVE-2018-14628
Low
—

Wykryto podatność na wyciek informacji w serwerze LDAP Samba. Z powodu braku odpowiednich kontroli dostępu, uwierzytelniony, ale nieuprzywilejowany atakujący mógłby odkryć nazwy i zachowane atrybuty usuniętych obiektów w magazynie LDAP.

CVE-2022-32743
Low
—

Samba nie weryfikuje poprawności atrybutu Validated-DNS-Host-Name dla atrybutu dNSHostName, co może pozwolić nieuprzywilejowanym użytkownikom na jego zapisanie.

CVE-2026-42040
Low
—

Axios to klient HTTP oparty na obietnicach dla przeglądarki i Node.js. W wersjach przed 1.15.1 i 0.31.1 funkcja encode() w pliku lib/helpers/AxiosURLSearchParams.js zawiera mapowanie znaków, które odwraca bezpieczne kodowanie procentowe bajtów null.

CVE-2017-7189
Low
—

W PHP 7.x przed 2017-03-07 występuje błąd w analizie wywołań fsockopen, który może prowadzić do nieprawidłowego interpretowania adresów i portów. Na przykład, wywołanie fsockopen('127.0.0.1:80', 443) może być zinterpretowane jako 127.0.0.1:80:443, co później jest skracane do 127.0.0.1:80.

CVE-2026-3455
Low
—

Wersje pakietu mailparser przed 3.9.3 są podatne na ataki Cross-site Scripting (XSS) poprzez funkcję textToHtml() z powodu niewłaściwego oczyszczania adresów URL w treści e-maili. Atakujący może wykonać dowolne skrypty w przeglądarkach ofiar, dodając dodatkowy znak cudzysłowu " do adresu URL.

CVE-2025-61144
Low
—

W wersjach libtiff do 4.7.1 odkryto podatność na przepełnienie stosu w funkcji readSeparateStripsIntoBuffer. Może to prowadzić do nieautoryzowanego dostępu do pamięci.

CVE-2026-2391
Low
—

Opcja `arrayLimit` w bibliotece qs nie egzekwuje limitów dla wartości oddzielonych przecinkami, gdy `comma: true` jest włączone, co pozwala atakującym na spowodowanie odmowy usługi poprzez wyczerpanie pamięci. Jest to obejście egzekwowania limitu tablicy, podobne do obejścia notacji nawiasowej omówionego w GHSA-6.

CVE-2026-5761
Medium
—

Podatność CVE-2026-5761 dotyczy komponentu virtio-blk, który może prowadzić do wyczerpania pamięci w buforze raportu strefy. Problem ten może wystąpić w wyniku nieprawidłowego zarządzania pamięcią.

GHSA-prq8-7wvh-44qh
High
—

In applications using OAuth::Consumer to request OAuth 1.0 tokens, the token request helper follows 300..399 redirects returned by the OAuth server. In affected versions, OAuth::Consumer#token_request parses the raw Location header and recursively follows the redirect.

CVE-2025-23048
Medium
—

W niektórych konfiguracjach mod_ssl na serwerze Apache HTTP w wersjach od 2.4.35 do 2.4.63 możliwe jest obejście kontroli dostępu przez zaufanych klientów przy użyciu wznowienia sesji TLS 1.3. Problematyczne są konfiguracje, w których mod_ssl jest ustawiony dla wielu wirtualnych hostów, z których każdy ma przypisany inny zestaw zaufanych klientów.

CVE-2025-49630
Medium
—

W określonych konfiguracjach proxy, atak typu denial of service na serwer Apache HTTP w wersjach od 2.4.26 do 2.4.63 może być wywołany przez nieufne klientów, co prowadzi do asercji w mod_proxy_http2. Dotyczy to konfiguracji, w której reverse proxy jest skonfigurowane dla zaplecza HTTP/2 z włączonym ProxyPreserve.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS