CVE Catalog

CVE-2026-85229

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.16%

5th percentile - higher than 5% of all known CVEs

Summary

Apache SkyWalking Booster UI (part of Apache SkyWalking UI) versions 10.2.0 through 10.4.0 are vulnerable to cross-site scripting (XSS) due to improper neutralization of input during web page generation. The product is marked as UNSUPPORTED WHEN ASSIGNED.

Risk Assessment

An attacker can inject malicious scripts into a user's browser, potentially leading to session theft, account takeover, or other malicious actions within the application context.

Recommendation

It is recommended to upgrade to Horizon UI 1.0.0, which fixes the issue, as Apache SkyWalking UI in these versions is no longer supported.

Related vulnerabilities

Original NVD description (English source)

** UNSUPPORTED WHEN ASSIGNED ** Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache SkyWalking Booster UI. This issue affects Apache SkyWalking UI : from 10.2.0 through 10.4.0. Users are recommended to upgrade to Horizon UI 1.0.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS