CVE-2026-6493
LowCVSS 3.5Exploitation Probability (EPSS)
Low risk18th percentile - higher than 18% of all known CVEs
Summary
A flaw has been found in lukevella rallly up to 4.7.4. It affects an unknown function in apps/web/src/app/[locale]/(auth)/reset-password/components/reset-password-form.tsx within the Reset Password Handler component. Manipulation of the redirectTo argument can lead to cross site scripting, and the attack can be executed remotely.
Risk Assessment
A public exploit is already available, increasing the risk of exploitation. This could lead to malicious script execution in the user's browser and session hijacking.
Recommendation
Upgrade rallly to version 4.8.0, which mitigates this issue. Immediate application of the update is advised.
Other vulnerabilities in rallly
See all- CVE-2025-65021Critical
Rallly prior to version 4.5.4 has an IDOR vulnerability in the poll finalization feature. Any authenticated user can finalize a poll they do not own by manipulating the pollId parameter, allowing unauthorized finalization and conversion to events.
- CVE-2026-92565Medium
An information disclosure vulnerability in Rallly before 4.15.0 in the polls.get tRPC procedure returns scheduled-event invitee names and email addresses to unauthenticated callers. Attackers can access a poll's urlId from public invite links to retrieve sensitive invitee information regardless of privacy settings.
- CVE-2025-66027Medium
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.6, an information disclosure vulnerability exposes participant details, including names and email addresses through the /api/trpc/polls.get,polls.participants.list endpoint, even when Pro privacy features are enabled. This bypasses intended privacy controls that should prevent participants from viewing other users' personal information. This issue has been patched in version 4.5.6.
- CVE-2025-65034High
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization vulnerability allows any authenticated user to reopen finalized polls belonging to other users by manipulating the pollId parameter.
- CVE-2025-65033High
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an authorization flaw in the poll management feature allows any authenticated user to pause or resume any poll, regardless of ownership, because the system identifies polls only by the public pollId.
- CVE-2025-65032Medium
Rallly, an open-source scheduling and collaboration tool, prior to version 4.5.4 has an Insecure Direct Object Reference (IDOR) vulnerability. It allows any authenticated user to change the display names of other participants in polls without being an admin or the poll owner.
- CVE-2025-65031Medium
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization flaw in the comment creation endpoint allows authenticated users to impersonate any other user by altering the authorName field in the API request.
- CVE-2025-65030High
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an authorization flaw in the comment deletion API allows any authenticated user to delete comments belonging to other users, including poll owners and administrators.
- CVE-2025-65029High
Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an insecure direct object reference (IDOR) vulnerability allows any authenticated user to delete arbitrary participants from polls without ownership verification, relying solely on a participant ID.
- CVE-2025-65028Medium
Rallly prior to version 4.5.4 has an insecure direct object reference (IDOR) vulnerability that allows any authenticated user to modify other participants' votes in polls without authorization. The backend relies solely on the participantId parameter without verifying ownership or poll permissions.
Original NVD description (English source)
A flaw has been found in lukevella rallly up to 4.7.4. This affects an unknown function of the file apps/web/src/app/[locale]/(auth)/reset-password/components/reset-password-form.tsx of the component Reset Password Handler. Executing a manipulation of the argument redirectTo can lead to cross site scripting. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 4.8.0 mitigates this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

