CVE Catalog

CVE-2026-63393

HighCVSS 8.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.50%

43th percentile - higher than 43% of all known CVEs

Summary

In OpenSearch SQL in the 2.x line from 2.8.0.0 until 2.19.6.0 and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted cursor parameter to the plugins/sql endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server.

Risk Assessment

An authenticated low-privileged user can execute arbitrary code on the OpenSearch server, leading to full compromise of the service and its data.

Recommendation

Update OpenSearch SQL to version 2.19.6.0 or 3.7.0.0 (or later) which contains the fix.

Related vulnerabilities

Original NVD description (English source)

OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted `cursor` parameter to the `plugins/sql` endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS