CVE Catalog

CVE-2026-6107

LowCVSS 3.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.21%

11th percentile - higher than 11% of all known CVEs

Summary

1Panel-dev MaxKB up to 2.6.1 contains a Cross-Site Scripting (XSS) vulnerability in the ChatHeadersMiddleware component (apps/common/middleware/chat_headers_middleware.py). Manipulating the Name argument enables remote attack. A fix was released in version 2.8.0 (commit 026a2d623e2aa5efa67c4834651e79d5d7cab1da).

Risk Assessment

An attacker could execute malicious script in a MaxKB user's browser, hijack sessions, or perform unauthorized actions. The risk is moderate but requires prompt patching.

Recommendation

Update MaxKB to version 2.8.0 or later. Until updated, consider restricting application access.

Other vulnerabilities in MaxKB

See all
Original NVD description (English source)

A flaw has been found in 1Panel-dev MaxKB up to 2.6.1. This issue affects some unknown processing of the file apps/common/middleware/chat_headers_middleware.py of the component ChatHeadersMiddleware. This manipulation of the argument Name causes cross site scripting. Remote exploitation of the attack is possible. Upgrading to version 2.8.0 is capable of addressing this issue. Patch name: 026a2d623e2aa5efa67c4834651e79d5d7cab1da. Upgrading the affected component is advised. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS