CVE Catalog

CVE-2026-58157

HighCVSS 8.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.49%

39th percentile - higher than 39% of all known CVEs

Summary

Apache Traffic Server can reuse server sessions and tunnels improperly, exposing data across client connections. Affected versions are from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, and from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4.

Risk Assessment

Sensitive data may leak between different clients, compromising confidentiality and integrity of communications.

Recommendation

Upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 to prevent unauthorized data exposure.

Other vulnerabilities in Apache Traffic Server

See all
Original NVD description (English source)

Apache Traffic Server can reuse server sessions and tunnels improperly, exposing data across client connections. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS