CVE Catalog

CVE-2026-47269

HighCVSS 7.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.31%

23th percentile - higher than 23% of all known CVEs

Summary

In pam_usb before 0.9.0, the deny_remote feature checks utmpx ut_addr_v6 but only tests the first 32-bit word of the 128-bit address. IPv4-mapped IPv6 addresses (::ffff:x.x.x.x) have a zero first word, so IPv4 SSH sessions are incorrectly treated as local. This allows bypassing the deny_remote restriction and authenticating over SSH with a registered USB device.

Risk Assessment

An attacker with physical access to a registered USB device can authenticate over SSH on an affected system despite deny_remote being enabled, undermining access control assumptions. This particularly affects Ubuntu and Debian systems where sshd listens on ::.

Recommendation

Update pam_usb to version 0.9.0 or later. Until patched, consider restricting deny_remote or forcing connections in a way that avoids IPv4-mapped addresses.

Other vulnerabilities in pam_usb

See all
Original NVD description (English source)

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.9.0, pam_usb's deny_remote feature checks utmpx ut_addr_v6 to detect whether an authentication request originates from a remote session. The outer guard was if (utent->ut_addr_v6[0] != 0), which only tests the first 32-bit word of the 128-bit address field. IPv4-mapped IPv6 addresses (::ffff:x.x.x.x) store the IPv4 address in ut_addr_v6[3] with ut_addr_v6[0] == 0. On systems where the SSH daemon listens on :: (IPv6 wildcard) with AddressFamily any -- common on Ubuntu and Debian -- incoming IPv4 connections are recorded in utmpx as IPv4-mapped IPv6 addresses. The outer check evaluates to false, the remote-detection block is skipped entirely, and the session is treated as local. deny_remote=true does not block the authentication. An attacker with physical access to a registered USB device can authenticate over SSH on an affected system as if they were sitting at a local terminal, bypassing the deny_remote restriction. This vulnerability is fixed in 0.9.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS