CVE Catalog

CVE-2026-42887

MediumCVSS 4.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.26%

17th percentile - higher than 17% of all known CVEs

Summary

Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.

Risk Assessment

An administrator or someone with a compromised admin account can execute malicious script in all users' browsers, potentially leading to credential theft.

Recommendation

Update Audiobookshelf to version 2.33.0 or later.

Other vulnerabilities in Audiobookshelf

See all
Original NVD description (English source)

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS