CVE Catalog

CVE-2026-42509

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.36%

29th percentile - higher than 29% of all known CVEs

Summary

Apache Wicket contains a Cross-site Scripting (XSS) vulnerability due to improper neutralization of input during web page generation. The issue affects versions from 8.0.0 through 8.17.0, 9.0.0, and from 10.0.0 through 10.8.0.

Risk Assessment

An attacker could inject malicious script executed in the user's browser, potentially leading to session or data theft.

Recommendation

Upgrade Apache Wicket to version 10.9.0, which fixes the issue.

Other vulnerabilities in Apache Wicket

See all
Original NVD description (English source)

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS