CVE Catalog

CVE-2026-12470

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.33%

27th percentile - higher than 27% of all known CVEs

Summary

The CMP – Coming Soon & Maintenance Plugin by NiteoThemes for WordPress is vulnerable to unauthorized modification of data leading to privilege escalation due to a missing capability check on the 'cmp_ajax_import_settings' AJAX action in all versions up to and including 4.1.17. An authenticated attacker with Editor-level access or above can update arbitrary options, including the default registration role to administrator.

Risk Assessment

An attacker can escalate privileges to administrator and take full control of the WordPress site, posing a serious threat to its security.

Recommendation

Update the CMP plugin to a version newer than 4.1.17 once a fix is available, and verify that user registration and default roles have not been altered.

Related vulnerabilities

Original NVD description (English source)

The CMP – Coming Soon & Maintenance Plugin by NiteoThemes plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'cmp_ajax_import_settings' AJAX action in all versions up to, and including, 4.1.17. This makes it possible for authenticated attackers, with Editor-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS