CVE Catalog

CVE-2026-120597

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Summary

A vulnerability was identified in the Welcart e-Commerce plugin for WordPress up to 2.12.6, affecting the ESCOTT_MAIN::error_page_message function in classes/paymentESCOTT.main.class.php. Manipulation of the ResponseCd argument leads to cross-site scripting, the attack can be launched remotely, and the exploit is publicly available.

Risk Assessment

Malicious script may execute in a user's browser, enabling session theft or compromise of the store administrator account.

Recommendation

Upgrade the Welcart e-Commerce plugin to version 2.12.7, where output is escaped with esc_html().

Related vulnerabilities

Original NVD description (English source)

A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS