CVE Catalog

CVE-2026-112105

LowCVSS 3.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.34%

26th percentile - higher than 26% of all known CVEs

Summary

A vulnerability was found in GlitterWare Passy up to 1.10.1 in the MyHttpOverrides function of lib/main.dart within the TLS handler component. Manipulation leads to improper certificate validation, and the attack may be launched remotely, though it is characterized by high complexity and difficult exploitability. Upgrading to version 1.10.2 fixes the issue (patch 3d48df7cce05e39fa4de1e42768492307f26882e).

Risk Assessment

Improper certificate validation may allow an attacker to intercept or impersonate a TLS connection, leading to data leakage or actions on behalf of the user. Due to the high attack complexity, the risk is limited but still relevant.

Recommendation

Upgrade GlitterWare Passy to version 1.10.2 or later. Until then, avoid processing sensitive data through the application.

Related vulnerabilities

Original NVD description (English source)

A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS