CVE Catalog

CVE-2026-107759

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.27%

20th percentile - higher than 20% of all known CVEs

Summary

The WPO365 | MICROSOFT 365 GRAPH MAILER plugin for WordPress (up to 6.2) is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter (e.g., from CF7). Insufficient input sanitization and output escaping allow unauthenticated attackers to inject arbitrary scripts that execute when a user visits an injected page. The payload is stored without authentication via any mail-sending feature when Graph Mailer is enabled but OAuth authorization is not completed.

Risk Assessment

An attacker can execute arbitrary JavaScript in the browser of a user visiting the infected page, potentially leading to session theft or other actions in the site context. This requires only unauthenticated access to the site.

Recommendation

Update the plugin to a version later than 6.2. Until then, ensure OAuth authorization is completed or disable the plugin.

Related vulnerabilities

Original NVD description (English source)

The WPO365 | MICROSOFT 365 GRAPH MAILER plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject (via wp_mail/PHPMailer, e.g. CF7 your-subject)' parameter in all versions up to, and including, 6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is stored without authentication via any mail-sending feature that forwards a submitter-controlled subject (e.g. a Contact Form 7 form) when the Graph Mailer is enabled but OAuth authorization has not been completed, a default state immediately after plugin activation.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS