CVE Catalog

CVE-2025-65960

MediumCVSS 6.6
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

7th percentile - higher than 7% of all known CVEs

Summary

Contao CMS from version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5 allows back end users with precise control over template closure contents to execute arbitrary PHP functions that do not have required parameters. This is patched in versions 4.13.57, 5.3.42, and 5.6.5.

Risk Assessment

A back end user could execute unauthorized PHP functions, potentially leading to further privilege escalation or code execution.

Recommendation

Update Contao to version 4.13.57, 5.3.42, or 5.6.5 (or later); a workaround is to manually patch the Contao\Template::once() method.

Other vulnerabilities in Contao

See all
Original NVD description (English source)

Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS