CVE Catalog

CVE-2025-64107

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.38%

31th percentile - higher than 31% of all known CVEs

Summary

In Cursor code editor versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes but not via backslashes, allowing an attacker with prompt injection or other control to overwrite sensitive editor files without approval on Windows machines.

Risk Assessment

An attacker who gains control (e.g., via prompt injection) can overwrite editor configuration files and achieve malicious code execution on the victim's machine.

Recommendation

Update Cursor to version 2.0 or later.

Other vulnerabilities in Cursor

See all
Original NVD description (English source)

Cursor is a code editor built for programming with AI. In versions 1.7.52 and below, manipulating internal settings may lead to RCE. Cursor detects path manipulation via forward slashes (./.cursor/./././././mcp.json etc.), and requires human approval to complete the operation. However, the same kind of manipulation using backslashes was not correctly detected, allowing an attacker who had already achieved prompt injection or some other level of control to overwrite sensitive editor files without approval on Windows machines. This issue is fixed in version 2.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS