CVE Catalog

CVE-2025-61591

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
1.16%

67th percentile - higher than 67% of all known CVEs

Summary

Cursor versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, allow an attacker to impersonate a malicious MCP server and return crafted, maliciously injected commands during interaction, leading to command injection and potential remote code execution. This could allow arbitrary code execution on the host by the agent with full user privileges. No fixed release version exists, but patch 2025.09.17-25b418f is available.

Risk Assessment

An attacker could execute arbitrary commands with user privileges, compromising the system, stealing data, or installing malware.

Recommendation

Apply patch 2025.09.17-25b418f or later. Avoid connecting to untrusted MCP servers via OAuth.

Other vulnerabilities in Cursor

See all
Original NVD description (English source)

Cursor is a code editor built for programming with AI. In versions 1.7 and below, when MCP uses OAuth authentication with an untrusted MCP server, an attacker can impersonate a malicious MCP server and return crafted, maliciously injected commands during the interaction process, leading to command injection and potential remote code execution. If chained with an untrusted MCP service via OAuth, this command injection vulnerability could allow arbitrary code execution on the host by the agent. This can then be used to directly compromise the system by executing malicious commands with full user privileges. This issue does not currently have a fixed release version, but there is a patch, 2025.09.17-25b418f.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS