CVE-2025-62513
HighCVSS 7.5Exploitation Probability (EPSS)
Low risk23th percentile - higher than 23% of all known CVEs
Summary
In OpenBao versions 2.2.0 to 2.4.1, the audit log failed to properly redact raw HTTP bodies for some endpoints. This may leak short-lived ACME verification codes and OIDC auth and token response codes along with claims in audit logs.
Risk Assessment
Leaked codes have limited long-term use but may facilitate short-term attacks. This breaches confidentiality of audit log data.
Recommendation
Update OpenBao to version 2.4.2. Review and secure existing audit logs.
Other vulnerabilities in OpenBao
See all- CVE-2026-42186High
OpenBao is an identity-based secrets management system. Prior to version 2.5.3, when the initial namespace deletion fails, subsequent retries do not properly remove all data before marking the namespace as deleted.
- CVE-2026-63132Critical
OpenBao is an open source identity-based secrets management system. Prior to 2.6.0, OpenBao's handleLogicalRecovery path in http/logical.go compared the highly privileged recovery token with ordinary string equality. A remote unauthenticated attacker able to make repeated recovery mode requests and measure response timing could infer the recovery token. The recovered token could then authorize recovery mode operations that read or modify OpenBao data. This issue is fixed in version 2.6.0.
- CVE-2026-33757Critical
OpenBao prior to version 2.5.2 does not prompt for user confirmation when logging in via JWT/OIDC with a role set to `callback_mode=direct`. This allows an attacker to perform remote phishing by having the victim visit a URL and automatically log into the attacker's session.
- CVE-2026-115369Low
OpenBao from 2.5.0 before 2.6.2 fails to enforce the PKI role allowed_ip_sans_cidr restriction on IP SANs taken from a CSR when use_csr_sans is enabled. Authenticated callers with sign permission can submit a CSR with an out-of-range IP SAN to pki/sign/<role> and obtain CA-signed certificates for unauthorized IPs.
- CVE-2026-115366Low
OpenBao from 2.3.0 before 2.6.3 contains an improper authorization vulnerability that allows privileged child-namespace tokens to modify plugin registrations because /v1/sys/plugins/catalog/* is not restricted to the root namespace. Attackers can remove existing registrations, create invalid ones, or register installed plugins through a child namespace's sys/ mount, causing denial of service.
- CVE-2026-115365Medium
An incorrect authorization vulnerability in OpenBao's ACL policy cache allows tokens to reference policies from arbitrary namespaces using specially crafted policy names. An attacker holding such tokens can gain capabilities of cached policies in other namespaces, including the root namespace, and act across namespace boundaries.
- CVE-2026-115364Low
OpenBao before 2.6.3 contains a missing authorization check that allows attackers to stop Agent and Proxy services by omitting the X-Vault-Header. When require_request_header is enabled, attackers can send requests via server-side request forgery to /agent/v1/quit or /proxy/v1/quit to shut down these services.
- CVE-2026-115363Low
OpenBao 2.2.0 before 2.6.4 and 2.7.0 before 2.7.1 contains an information disclosure vulnerability that exposes the tls_acme_eab_mac_key value through the sys/config/state/sanitized endpoint. Callers of the sanitized configuration endpoint can retrieve the ACME External Account Binding MAC key used for TLS listener certificates, letting them bind to the operator's ACME account.
- CVE-2026-115362Low
OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not check Secret ID expiration at use in the AppRole auth method, leaving expired Secret IDs valid until the periodic tidy removes them. An attacker holding an expired, untidied Secret ID can log in and gain access beyond its TTL.
- CVE-2026-115361Medium
An ACL bypass vulnerability in OpenBao silently drops explicit deny rules based on forbidden identity metadata templates within wildcard grants. An attacker whose identity metadata contains wildcard or path segments can access paths that should be denied within the broader wildcard-granted scope.
Original NVD description (English source)
OpenBao is an open source identity-based secrets management system. In versions 2.2.0 to 2.4.1, OpenBao's audit log experienced a regression wherein raw HTTP bodies used by few endpoints were not correctly redacted (HMAC'd). This impacts those using the ACME functionality of PKI, resulting in short-lived ACME verification challenge codes being leaked in the audit logs. Additionally, this impacts those using the OIDC issuer functionality of the identity subsystem, auth and token response codes along with claims could be leaked in the audit logs. ACME verification codes are not usable after verification or challenge expiry so are of limited long-term use. This issue has been patched in OpenBao 2.4.2.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

