CVE Catalog

CVE-2025-55173

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.60%

48th percentile - higher than 48% of all known CVEs

Summary

Next.js Image Optimization in versions before 14.2.31 and from 15.0.0 to before 15.4.5 is vulnerable to content injection. An attacker could supply external image sources that trigger file downloads with arbitrary content and filenames, which could be abused for phishing or malicious file delivery.

Risk Assessment

Users may be tricked into downloading malicious files, potentially leading to infection or data theft.

Recommendation

Update Next.js to version 14.2.31 or 15.4.5 (or later) and consider restricting allowed external image sources.

Other vulnerabilities in Next.js

See all
Original NVD description (English source)

Next.js is a React framework for building full-stack web applications. In versions before 14.2.31 and from 15.0.0 to before 15.4.5, Next.js Image Optimization is vulnerable to content injection. The issue allowed attacker-controlled external image sources to trigger file downloads with arbitrary content and filenames under specific configurations. This behavior could be abused for phishing or malicious file delivery. This vulnerability has been fixed in Next.js versions 14.2.31 and 15.4.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS