CVE-2025-12743
MediumCVSS 6.0Exploitation Probability (EPSS)
Low risk19th percentile - higher than 19% of all known CVEs
Summary
The Looker endpoint for generating new projects from database connections allows users to specify "looker" as a connection name, a reserved internal name for Looker's internal MySQL database. The schemas parameter is vulnerable to SQL injection, enabling attackers to manipulate SELECT queries executed against the internal MySQL database, allowing users with developer permissions to extract data.
Risk Assessment
Users with developer permissions can extract data from Looker's internal MySQL database, breaching platform data confidentiality. Both Looker-hosted and self-hosted instances are affected.
Recommendation
For self-hosted instances, upgrade Looker immediately to a patched version (e.g., 24.12.106, 24.18.198+, 25.0.75, 25.6.63+, 25.8.45+, 25.10.33+, 25.12.1+, 25.14+). Hosted instances have already been mitigated by the vendor.
Other vulnerabilities in Looker
See all- CVE-2025-12414Critical
In Looker configured with OIDC authentication, an attacker could take over a user account due to email address string normalization. Looker-hosted and Self-hosted were vulnerable; hosted is mitigated, self-hosted needs upgrade.
- CVE-2025-12742High
A Looker user with a Developer role could cause Looker to execute a malicious command due to insecure processing of Teradata driver parameters. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances; no user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted (24.12.108+, 24.18.200+, 25.0.78+, 25.6.65+, 25.8.47+, 25.12.10+, 25.14+).
- CVE-2025-12741High
A Looker user with Developer role could create a database connection using Denodo driver and manipulate LookML to execute a malicious command. Looker-hosted and Self-hosted are vulnerable; hosted is mitigated, self-hosted needs upgrade.
- CVE-2025-12740High
A Looker user with Developer role could create a database connection using IBM DB2 driver and manipulate LookML to execute a malicious command due to inadequate filtering. Looker-hosted and Self-hosted are vulnerable; hosted is mitigated, self-hosted needs upgrade.
- CVE-2025-12739High
An attacker with viewer permissions in Looker could craft a malicious URL that, when opened by a Looker admin, would execute an attacker-supplied script. Exploitation required at least one Looker extension installed on the instance.
- CVE-2025-12472High
An attacker with a Looker Developer role could manipulate a LookML project to exploit a race condition during Git directory deletion, leading to arbitrary command execution on the Looker instance. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted.
- CVE-2025-12155High
A Command Injection vulnerability, resulting from improper file path sanitization (Directory Traversal) in Looker allows an attacker with Developer permission to execute arbitrary shell commands when a user is deleted on the host system. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect from this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : 24.12.100+, 24.18.192+, 25.0.69+, 25.6.57+, 25.8.39+, 25.10.22+
Original NVD description (English source)
The Looker endpoint for generating new projects from database connections allows users to specify "looker" as a connection name, which is a reserved internal name for Looker's internal MySQL database. The schemas parameter is vulnerable to SQL injection, enabling attackers to manipulate SELECT queries that are constructed and executed against the internal MySQL database. This vulnerability allows users with developer permissions to extract data from Looker's internal MySQL database. Looker-hosted and Self-hosted were found to be vulnerable. This issue has already been mitigated for Looker-hosted instances. No user action is required for these. Self-hosted instances must be upgraded as soon as possible. This vulnerability has been patched in all supported versions of Self-hosted. The versions below have all been updated to protect against this vulnerability. You can download these versions at the Looker download page https://download.looker.com/ : * 24.12.106 * 24.18.198+ * 25.0.75 * 25.6.63+ * 25.8.45+ * 25.10.33+ * 25.12.1+ * 25.14+
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

