CVE Catalog

CVE-2022-27774

MediumCVSS 5.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
1.87%

79th percentile - higher than 79% of all known CVEs

Summary

A vulnerability in curl from version 4.9 up to and including 7.82.0 related to insufficient protection of credentials. When following HTTP(S) redirects with authentication, credentials may leak to other services on different protocols or ports.

Risk Assessment

An attacker could obtain authentication data and use it for unauthorized access to other services.

Recommendation

Update curl to version 7.83.0 or later to fix the vulnerability.

Other vulnerabilities in curl

See all
Original NVD description (English source)

An insufficiently protected credentials vulnerability exists in curl 4.9 to and include curl 7.82.0 are affected that could allow an attacker to extract credentials when follows HTTP(S) redirects is used with authentication could leak credentials to other services that exist on different protocols or port numbers.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS