CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.23)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

DSA-6572-1
Unknown
—

No vulnerability description is available in the provided NVD data. Technical details and impact scope cannot be determined from the supplied information.

CVE-2024-38475
CriticalActively exploited
—

Improper escaping of output in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to map URLs to filesystem locations that are permitted to be served but not directly reachable, leading to code execution or source code disclosure.

CVE-2026-31524
Medium
—

W jądrze Linuxa zidentyfikowano podatność związaną z funkcją asus_report_fixup(), która zwracała nowo przydzielony bufor, ale nigdy go nie zwalniała. Zmieniono ją na devm_kzalloc(), aby zapewnić zarządzanie pamięcią.

DLA-4845-1
Unknown
—

No vulnerability description is available in the provided NVD data. Technical details and impact scope cannot be determined from the supplied information.

CVE-2026-33660
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.14.1, 2.13.3 i 1.123.26, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wykorzystać tryb 'Combine by SQL' w węźle Merge do odczytu lokalnych plików na hoście n8n oraz uzyskać zdalne wykonanie kodu.

CVE-2026-33864
Critical
—

W najnowszej wersji pakietu convict npm (6.2.4) występuje podatność na zanieczyszczenie prototypu. Mimo wcześniejszej poprawki, która miała na celu ograniczenie zanieczyszczenia prototypu poprzez sprawdzanie, czy dane wejściowe użytkownika zaczynają się od zastrzeżonego klucza, nadal możliwe jest zanieczyszczenie `Object.prototype`.

CVE-2026-33863
Critical
—

Istnieją dwie niechronione ścieżki zanieczyszczenia prototypu, które nie zostały objęte wcześniejszymi poprawkami. Funkcje `config.load()` i `config.loadFile()` rekurencyjnie łączą dane konfiguracyjne bez sprawdzania zabronionych kluczy, co może prowadzić do poważnych problemów.

CVE-2025-7458
Critical
—

Przepełnienie całkowitej liczby w funkcji sqlite3KeyInfoFromExprList w wersjach SQLite od 3.39.2 do 3.41.1 może pozwolić atakującemu na wykonanie dowolnych poleceń SQL. Może to prowadzić do odmowy usługi lub ujawnienia wrażliwych informacji z pamięci procesu poprzez odpowiednio skonstruowane zapytanie SELECT.

CVE-2025-8961
Low
—

Wykryto słabość w LibTIFF 4.7.0, która dotyczy funkcji main w pliku tiffcrop.c komponentu tiffcrop. Manipulacja tą funkcją może prowadzić do uszkodzenia pamięci.

CVE-2026-1470
Critical
—

n8n zawiera krytyczną podatność na zdalne wykonanie kodu (RCE) w systemie oceny wyrażeń workflow. Wyrażenia dostarczane przez uwierzytelnionych użytkowników podczas konfiguracji workflow mogą być oceniane w kontekście wykonawczym, który nie jest wystarczająco izolowany od podstawowego środowiska wykonawczego.

CVE-2026-25052
Critical
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 1.123.18 i 2.5.0 istniała podatność w kontrolach dostępu do plików, która pozwalała uwierzytelnionym użytkownikom z uprawnieniami do tworzenia lub modyfikowania procesów roboczych na odczyt wrażliwych plików z systemu hosta n8n.

CVE-2024-47252
Medium
—

Niewystarczające zabezpieczenie danych dostarczanych przez użytkownika w mod_ssl w Apache HTTP Server 2.4.63 i wcześniejszych wersjach pozwala na wprowadzenie znaków ucieczki do plików dziennika przez nieufnego klienta SSL/TLS w niektórych konfiguracjach.

CVE-2025-31160
Medium
—

Wersja atop do 2.11.0 pozwala lokalnym użytkownikom na wywołanie odmowy usługi (np. awaria asercji i zakończenie aplikacji) lub potencjalnie inny nieokreślony wpływ, gdy różni użytkownicy uruchamiają atop oraz nieuprzywilejowane procesy.

CVE-2026-2581
Medium
—

Jest to podatność na niekontrolowane zużycie zasobów (CWE-400), która może prowadzić do ataku typu Denial of Service (DoS). W podatnych wersjach Undici, gdy włączona jest funkcja interceptors.deduplicate(), dane odpowiedzi dla zduplikowanych żądań mogą być gromadzone w pamięci dla dalszych handlerów.

CVE-2026-41907
Medium
—

Podatność w uuid, która występuje przed wersją 14.0.0, pozwala na zapisanie danych poza zakresem w buforach dostarczonych przez użytkownika. Wersje v3, v5 i v6 nie odrzucają takich zapisów, co prowadzi do cichych, częściowych zapisów.

CVE-2023-46045
Medium
—

Graphviz w wersjach od 2.36.0 do 9.x przed 10.0.1 ma podatność na odczyt poza przydzielonym zakresem za pomocą spreparowanego pliku config6a. Warto zauważyć, że możliwość wykorzystania tej podatności może być rzadko spotykana, ponieważ plik ten jest zazwyczaj własnością użytkownika root.

CVE-2024-38474
Medium
—

Problem z kodowaniem substytucyjnym w mod_rewrite w Apache HTTP Server 2.4.59 i wcześniejszych wersjach umożliwia atakującemu wykonywanie skryptów w katalogach dozwolonych przez konfigurację, ale niedostępnych bezpośrednio przez jakikolwiek URL, co może prowadzić do ujawnienia skryptów przeznaczonych do wykonywania jako CGI.

CVE-2025-7783
Critical
—

Podatność związana z używaniem niewystarczająco losowych wartości w form-data umożliwia atak typu HTTP Parameter Pollution (HPP). Dotyczy to plików programowych lib/form_data.Js oraz wersji form-data: < 2.5.4, 3.0.0 - 3.0.3, 4.0.0 - 4.0.3.

CVE-2026-1525
Medium
—

Undici pozwala na duplikowanie nagłówków HTTP Content-Length, gdy są one podawane w tablicy z nazwami o różnych wielkościach liter (np. Content-Length i content-length). To prowadzi do nieprawidłowych żądań HTTP/1.1 z wieloma sprzecznymi wartościami Content-Length.

CVE-2022-48064
Low
—

W wersjach GNU Binutils przed 2.40 odkryto podatność na nadmierne zużycie pamięci w funkcji bfd_dwarf2_find_nearest_line_with_alt w pliku dwarf2.c. Atakujący może dostarczyć spreparowany plik ELF, co może prowadzić do ataku DNS.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS