CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.11.03)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
In Echo before 4.16.0 and 5.4.0, Context.JSONP and Context.JSONPBlob concatenate an unvalidated callback value into a JavaScript response. A route passing attacker-controlled input as the callback can return executable script syntax, enabling reflected cross-site scripting.
In Echo from 4.0.0 until 5.4.0, the Proxy middleware can preserve an attacker-supplied X-Real-IP header and forward it to an upstream service when Echo.IPExtractor is not configured. A remote client can thus make upstream services receive a spoofed client address.
In the Echo Go web framework prior to 4.16.0 and 5.4.0, the MethodOverride middleware accepts a safe HTTP method as the override target for a POST request. When MethodOverride is registered before CSRF in the post-routing middleware chain, route selection retains the original state-changing POST handler but the override changes the method before CSRF evaluates it, causing both token validation and Sec-Fetch-Site checks to be skipped. A cross-site exploit requires an authenticated victim and an override value controllable by a browser-submitted request, such as the form getter used by the advisory reproducer; the default X-HTTP-Method-Override header getter is not settable by a cross-site form.
Improper neutralization of input used for LLM prompting in the environment tool in Strands Agents Tools before 0.8.6 might allow remote actors to obtain the agent host's environment variables in cleartext, including cloud credentials and API keys, via a crafted prompt that disables the tool's secret masking. To remediate this issue, users should upgrade to version 0.8.6 or later and rotate any credentials that were present in the environment of agents that loaded the environment tool.
Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0 before 2.36.7, and 2.37.0 before 2.37.4 does not validate the audience claim of GCE instance-identity JWTs at the POST /api/v2/workspaceagents/google-instance-identity endpoint. Attackers who obtain an unexpired format=full identity token minted for another relying party can replay it to obtain that workspace agent's session token, which remains valid until the workspace's next build.
ToolJet from 3.20.2-lts before 3.20.242-lts contains an authorization bypass in SignupDisableGuard, which treats the string signup setting 'false' as truthy, so instance-level signup restrictions are not enforced. Unauthenticated attackers can send POST requests to /api/signup without an organizationId to create an account, join the default workspace, and receive a valid session.
MONAI before 1.6.1 contains an insufficient integrity verification vulnerability in check_hash() that silently returns True when hash_val is None, with MD5 as the default hash type. Attackers performing man-in-the-middle or registry compromise can substitute bundles, datasets, or model archives downloaded without hashes, enabling malicious file delivery and potential code execution.
SiYuan 3.8.7 through 3.8.8 fails to normalize Windows GLOBALROOT device-namespace aliases, bypassing the IsSensitivePath denylist. Attackers can invoke importStdMd with a GLOBALROOT-prefixed path to copy the API token and TLS private key into the publicly served assets directory.
n8n before 2.41.4 and 2.42.x before 2.42.1 contains a missing confirmation vulnerability in the Local Gateway desktop app that allows its deep-link connect handler to silently re-pair the app with a different n8n instance. Attackers can lure users running the Local Gateway into opening a crafted n8n-computer-use:// link to connect their computer to an attacker-controlled instance, inheriting previously granted permissions and acting on the computer through the gateway.
n8n before 1.123.85, 2.43.5, and 2.44.1 contains a regular expression denial of service vulnerability. Authenticated members can create and run workflows with wildcard-heavy File(s) Selector glob patterns that cause exponential backtracking and block the event loop.
n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass in Chat Hub. Users with the global:chatUser role can register restricted tool types and run them via chat to execute sandboxed code, access permitted files, and use instance workflows, Data Tables, and agents.
Echo, a Go web framework, from 5.0.0 until 5.4.1 has a vulnerability in ExtractIPFromRealIPHeader that validates the client-supplied X-Real-IP value instead of the direct network peer. A client can supply a loopback or private address and have Context.RealIP return that spoofed identity.
Echo, a Go web framework, from 5.0.0 until 5.4.1 has a vulnerability in BodyDump middleware that can discard a BodyLimit overflow error for an unknown-length request when BodyDump's capture limit is below the BodyLimit threshold. An HTTP/1.1 chunked request can be truncated and processed successfully despite exceeding the configured limit.
opentelemetry-java before 1.67.0 has a vulnerability in W3CTraceContextPropagator.extract() where regex delimiter processing can exhibit quadratic backtracking when parsing tracestate headers with long runs of spaces or tabs without a following comma. An unauthenticated attacker can block request threads and cause excessive CPU consumption.
Insufficient policy enforcement in chrome-devtools-mcp in Google Chrome on Linux prior to 1.5.0 allows a local attacker to perform arbitrary read/write via a malicious file.
A user with read access to Grafana's server logs or a log store they are shipped to can recover OAuth and OIDC access, refresh, and ID tokens of users signing in through Generic OAuth, Google, or GitLab providers. Grafana writes these tokens unredacted when a token is not a valid JWT, when the ID token is missing (at debug level), or is not a string. Exposure is bounded by the scopes granted to the OAuth client.
Don't Starve Together (Steam AppID 322330) through build 747465 contains a memory-corruption vulnerability in the native persistent-string decoder. A remote attacker operating a public dedicated server can crash a victim's game client by publishing crafted world_gen_data with an invalid Klei persistent blob header length, causing remote denial of service.
Highcharts Dashboards edit mode walks editableOptions propertyPath segments without rejecting prototype-related keys. An attacker controlling editableOptions can provide a path through __proto__ or constructor, and a user's edit writes the configured value onto Object.prototype, affecting JavaScript throughout the page. This is fixed in 4.2.2.
Highcharts DataTable single-cell writers use an untrusted column ID as a key without rejecting __proto__ or constructor. DataTable.setCell, including Dashboards connector write-back and Grid Pro editing paths, can write integer-indexed values onto Object.prototype or the Object constructor, affecting array and object reads and for-in enumeration throughout the page. This is fixed in Dashboards 4.2.2 and Grid Pro 3.2.0.
Highcharts Dashboards stores DataCursor listener and state maps in plain objects keyed by DataTable ID. A __proto__ table ID supplied through dataPool connector configuration resolves to Object.prototype, creating an enumerable property visible on every object that can throw and break features such as extremes synchronization. The issue affects versions 1.0.0 through 4.2.2 and is fixed in 4.2.2.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

