CVE Catalog

CVE-2026-91002

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.44%

38th percentile - higher than 38% of all known CVEs

Summary

A weakness has been identified in stamparm maltrail up to 3.0.1 in the _blacklist function of core/httpd.py in the Blacklist Endpoint component. Manipulation can lead to missing authentication. The attack can be launched remotely and a public exploit is available. The issue is fixed in version 3.1.

Risk Assessment

A remote attacker could access the blacklist endpoint without authentication, potentially leading to unauthorized actions. The public availability of the exploit increases the risk.

Recommendation

Upgrade maltrail to version 3.1 or later (patch d95868dff3da4d3bd4f942837a26cb7c73a797ae). Ensure the endpoint is gated on an authenticated session or the Blacklist_ALLOWLIST option.

Related vulnerabilities

Original NVD description (English source)

A weakness has been identified in stamparm maltrail up to 3.0.1. This vulnerability affects the function _blacklist of the file core/httpd.py of the component Blacklist Endpoint. Executing a manipulation can lead to missing authentication. The attack can be launched remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.1 is able to resolve this issue. This patch is called d95868dff3da4d3bd4f942837a26cb7c73a797ae. It is suggested to upgrade the affected component. The vendor fixed the issue the same day it was reported, in version 3.1, by gating the endpoint on an authenticated session or the new Blacklist_ALLOWLIST option.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS