CVE-2026-88922
MediumCVSS 6.7Exploitation Probability (EPSS)
Low risk0th percentile - higher than 0% of all known CVEs
Summary
The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process.
Risk Assessment
A local attacker may escalate privileges to the level of the process extracting the archive, potentially leading to full system compromise.
Recommendation
Update the go-getter library to version 1.8.9 or 2.2.4, and avoid extracting untrusted archives as a privileged user.
Other vulnerabilities in go-getter
Original NVD description (English source)
The go-getter library up to versions 1.8.8 and 2.2.3 is vulnerable to a privilege escalation issue in its archive decompression handling that may allow a crafted archive to cause extracted files to be created with elevated permission bits. Where extraction is performed by a privileged user, this may allow a local actor to obtain the privileges of the extracting process. This vulnerability (CVE-2026-88922) is fixed in go-getter 1.8.9 and 2.2.4.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

