CVE Catalog

CVE-2026-8700

HighCVSS 7.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.36%

29th percentile - higher than 29% of all known CVEs

Summary

Crypt::DSA versions before 1.20 for Perl generate seeds using the rand function, which is predictable and unsuitable for security usage.

Risk Assessment

The use of predictable seeds may weaken cryptographic security, exposing the organization to attacks.

Recommendation

It is recommended to upgrade to Crypt::DSA version 1.20 or newer to ensure proper seed generation.

Other vulnerabilities in Crypt::DSA

See all
Original NVD description (English source)

Crypt::DSA versions before 1.20 for Perl generate seeds using rand. Seeds were generated using Perl's built-in rand function, which is predictable and unsuitable for security usage.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS