CVE Catalog

CVE-2026-85243

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.37%

31th percentile - higher than 31% of all known CVEs

Summary

Improper validation of the integrity check value in Apache Camel Crypto PGP component. The unmarshal() method verified the modification detection code only for OpenPGP symmetrically encrypted integrity protected data packets, skipping the check for older packets without such code, allowing the sender or a man-in-the-middle to decide whether integrity protection applied.

Risk Assessment

The organization may process unauthenticated or tampered PGP messages, leading to data integrity loss and potential content injection. The risk is especially relevant for environments accepting encrypted messages from untrusted senders.

Recommendation

Upgrade Apache Camel to version 4.23.0, 4.18.5, or 4.22.1, which introduce the requireIntegrityProtection option defaulting to true. If immediate upgrade is not possible, reject messages that do not use the integrity protected packet before they reach the data format.

Related vulnerabilities

Original NVD description (English source)

Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. unmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected data packet. The older symmetrically encrypted data packet carries no such code, and OpenPGP's CFB mode is malleable without one, so a message using that packet skipped the check altogether. The packet type is chosen by whoever produced the message, which left the sender - or anyone able to rewrite the message in transit - deciding whether the integrity check applied at all. The existing integrity option governs marshalling only and had no decrypt-side counterpart, so a deployment could not require integrity protection on the messages it accepted. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A requireIntegrityProtection option, defaulting to true, now rejects a message that is not integrity protected. Note that signatureVerificationOption still defaults to optional, so a message carrying no signature is accepted; the two options together are what give a decrypted message authenticity and not only confidentiality. For deployments that cannot upgrade immediately, reject messages that do not use the integrity protected packet before they reach the data format. Routes that must interoperate with a sender still emitting the legacy packet should set requireIntegrityProtection=false after upgrading, and treat the decrypted content as unauthenticated.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS