CVE Catalog

CVE-2026-84293

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

22th percentile - higher than 22% of all known CVEs

Summary

The Repeater Fields for Gravity Forms plugin for WordPress up to version 3.0.4 is vulnerable to Stored Cross-Site Scripting via Repeated Multi-Input Sub-Field Values. Insufficient input sanitization and output escaping allow unauthenticated attackers to inject arbitrary web scripts that execute when a user accesses an injected page.

Risk Assessment

An attacker can inject malicious scripts, potentially leading to data theft, session hijacking, or other harmful actions in the user's browser context.

Recommendation

Update the plugin to a version newer than 3.0.4 if available, or apply additional protections such as a Web Application Firewall (WAF).

Related vulnerabilities

Original NVD description (English source)

The Repeater Fields for Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Repeated Multi-Input Sub-Field Values in all versions up to, and including, 3.0.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability only affects multi-input sub-field types within a repeater (such as Name, Address, and Checkbox fields), as scalar single-input field values are escaped with esc_html() at the output stage in version 3.0.4.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS