CVE Catalog

CVE-2026-81754

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.24%

15th percentile - higher than 15% of all known CVEs

Summary

The Vigilant – 100% Free Security Suite plugin for WordPress (versions up to and including 2.10.2) is vulnerable to Stored Cross-Site Scripting via the User-Agent header due to insufficient input sanitization and output escaping. The malicious payload is delivered passively by any unauthenticated visitor who triggers a failed login attempt with a crafted User-Agent header.

Risk Assessment

An unauthenticated attacker can inject malicious scripts that execute for users visiting the affected page, potentially leading to data theft or session hijacking.

Recommendation

Update the plugin to a version newer than 2.10.2 or disable it if no fix is available.

Related vulnerabilities

Original NVD description (English source)

The Vigilant – 100% Free Security Suite: Firewall, 2FA, Login, Headers, Scanner… plugin for WordPress is vulnerable to Stored Cross-Site Scripting via User-Agent Header in all versions up to, and including, 2.10.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The malicious payload is delivered passively by any unauthenticated visitor who triggers a failed login attempt with a crafted User-Agent header, requiring no further interaction from the attacker once stored.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS