CVE Catalog

CVE-2026-80343

HighCVSS 8.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.45%

38th percentile - higher than 38% of all known CVEs

Summary

The Netty HTTP component in Apache Camel (versions 4.0.0–4.18.4 and 4.19.0–4.22.0) compares the request path against the security context path case-sensitively, while routing does not. Changing the case of a path segment bypasses the security constraint and reaches the protected route without satisfying it.

Risk Assessment

An external caller can access protected endpoints without the required credentials. No prior access or special configuration is needed beyond the ability to send a request.

Recommendation

Upgrade Apache Camel to 4.23.0 (or 4.18.5 / 4.22.1 on the LTS streams). If upgrading is not possible, place the authorization decision in front of the Camel consumer, e.g. in a reverse proxy that normalizes the request path.

Other vulnerabilities in Apache Camel

See all
Original NVD description (English source)

Improper Handling of Case Sensitivity vulnerability in Apache Camel Netty HTTP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The camel-netty-http security constraint compared the request path against the configured context path using a case-sensitive match, while the routing that dispatches the request to the endpoint did not apply the same rule. The two comparisons therefore disagreed for any path whose case differed from the configured value. An external caller could alter the case of a character in a path segment so that the security constraint no longer recognised the path as protected, while the request still dispatched to the same endpoint. The result is that the constraint is skipped and the protected route is reached without satisfying it. No credential, prior access or special configuration is required beyond being able to send a request to the consumer. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The constraint now matches the request path with the same case rules the dispatch uses, so the two can no longer disagree. For deployments that cannot upgrade immediately, place the authorization decision in front of the Camel consumer, for example in a reverse proxy that normalises the request path before forwarding.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS