CVE Catalog

CVE-2026-73494

HighCVSS 7.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.63%

48th percentile - higher than 48% of all known CVEs

Summary

In the blaze Scala library prior to 0.23.18 and from 1.0.0-M1 to 1.0.0-M42, the hand-written HTTP/1.1 parser accepts invalid header names, obsolete folded lines, unsupported Transfer-Encoding values, duplicate Content-Length fields, and requests with both Transfer-Encoding and Content-Length. Parser disagreement with a fronting intermediary can enable authorization bypass, response-queue poisoning, or cache poisoning.

Risk Assessment

If a lenient or legacy proxy fronts the application, an attacker can exploit parsing differences to bypass authorization or poison caches, threatening data confidentiality and integrity.

Recommendation

Upgrade blaze to 0.23.18 or 1.0.0-M42, and until then ensure fronting proxies enforce strict HTTP/1.1 parsing.

Other vulnerabilities in blaze

Original NVD description (English source)

blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. Prior to 0.23.18 and from 1.0.0-M1 until 1.0.0-M42, five HTTP/1.1 conformance laxities in the hand-written Java parser under http/src/main/java/org/http4s/blaze/http/parser/ can cause blaze to derive a different request boundary than a stricter fronting intermediary. A default BlazeServerBuilder accepts invalid or valueless header field names that violate tchar syntax, obsolete folded field lines (obs-fold), unsupported Transfer-Encoding values, duplicate Content-Length fields, and requests containing both Transfer-Encoding and Content-Length. If a lenient or legacy proxy forwards the malformed bytes but interprets them differently, the disagreement can permit front-end authorization bypass, response-queue poisoning on pooled backend connections, or cache poisoning. Exploitation requires a pair of disagreeing parsers; no non-default blaze configuration is required. The affected checks are enforced in BodyAndHeaderParser and Http1ServerParser. This issue is fixed in versions 0.23.18 and 1.0.0-M42.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS