CVE Catalog

CVE-2026-73322

Low risk· EPSS 7%
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

7th percentile - higher than 7% of all known CVEs

Summary

An incorrect authorization vulnerability exists in the single-stage query engine of Apache Pinot. When broker access control is enabled, the engine authorizes only the table named in the query's FROM clause, ignoring the dimension table identified by the `lookup()` transform function. An authenticated user authorized for at least one table can read columns from any dimension table in the cluster, including tables they have no access to, and retrieve arbitrary rows by supplying primary key values. Per-principal row-level security filters are also not applied. This affects Apache Pinot through 1.5.1 and is fixed in 1.6.0.

Risk Assessment

A user with limited privileges can access data from tables they should not have access to, violating confidentiality and access control. This may lead to leakage of sensitive information.

Recommendation

Upgrade Apache Pinot to version 1.6.0 or later. Until updated, consider disabling the `lookup()` function or tightening access controls.

Related vulnerabilities

Original NVD description (English source)

Incorrect Authorization vulnerability in the single-stage query engine of Apache Pinot. When broker access control is enabled, the single-stage query engine authorizes only the table named in the query's FROM clause. The lookup() transform function identifies its dimension table with a string literal argument rather than through the FROM clause, so that table was never included in the authorization check. An authenticated user who is authorized for at least one table can therefore read columns from any dimension table in the cluster, including tables they have no access to, and can retrieve arbitrary rows of it by supplying primary key values directly. Per-principal row-level security filters configured on the dimension table are likewise not applied. The multi-stage query engine is not affected. This issue affects Apache Pinot: through 1.5.1 Users are recommended to upgrade to version 1.6.0, which fixes this issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS