CVE Catalog

CVE-2026-7015

LowCVSS 2.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.22%

12th percentile - higher than 12% of all known CVEs

Summary

A vulnerability has been found in MaxSite CMS up to 109.3. Some unknown processing of the Guestbook Plugin component is affected. Manipulation of the f_text/f_slug/f_limit/f_email argument leads to cross site scripting, the attack may be launched remotely, and the exploit has been disclosed publicly. The vendor classifies it as "Self-XSS" and recommends upgrading to 109.4.

Risk Assessment

A remote attacker can inject script executed in a user's browser, potentially stealing sessions. The vendor considers the risk limited (Self-XSS), but the public exploit still poses a threat.

Recommendation

Upgrade MaxSite CMS to version 109.4, which contains the fix (commit 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7). Until updated, limit use of the Guestbook plugin.

Other vulnerabilities in MaxSite CMS

See all
Original NVD description (English source)

A vulnerability has been found in MaxSite CMS up to 109.3. This issue affects some unknown processing of the component Guestbook Plugin. Such manipulation of the argument f_text/f_slug/f_limit/f_email leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 109.4 is capable of addressing this issue. The name of the patch is 8a3946bd0a54bfb72a4d57179fcd253f2c550cd7. It is suggested to upgrade the affected component. The vendor was informed early about this issue. They classify it as a "Self-XSS". They deployed a countermeasure: "Nevertheless, we consider this a violation of secure coding standards. The lack of filtering via `htmlspecialchars()` has already been fixed in the latest patch to prevent incorrect data display."

Vulnerability data from NVD (NIST) · CISA KEV · EPSS