CVE Catalog

CVE-2026-69249

HighCVSS 8.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.25%

16th percentile - higher than 16% of all known CVEs

Summary

python-cryptography versions 42.0.0 through 48.0.0 have a denial-of-service vulnerability caused by exponential processing time when resolving invalid certificate chains containing duplicate self-signed certificates. The issue stems from the recursive build_chain_inner function that does not de-duplicate candidates. Fixed in version 49.0.0.

Risk Assessment

An attacker can exploit this to cause denial of service, severely slowing or blocking applications that use the library for certificate validation. System integrity is not affected, but availability can be compromised.

Recommendation

Upgrade python-cryptography to version 49.0.0 or later as soon as possible to mitigate the issue.

Other vulnerabilities in python-cryptography

Original NVD description (English source)

python-cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In versions 42.0.0 through 48.0.0, when resolving invalid certificate chains that include duplicate copies of self-signed certificates, the processing recursively invokes the same candidate, leading to an exponential blowup. Although the limitation that the chain depth cannot exceed a specified maximum depth prevents unbounded recursion and guarantees termination, an attacker-controlled certificate chain can lead the processing to easily take more than 5s to reject in testing. This amplification could form the basis for a resource exhaustion denial of service attack. The core issue arises in the recursive nature of build_chain_inner, which does not de-duplicate against previously analyzed candidates. As the correctness of validation is not affected, the integrity of a system cannot be compromised through this vector, only its availability. This issue is fixed in 49.0.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS