CVE Catalog

CVE-2026-6053

MediumCVSS 5.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.14%

3th percentile - higher than 3% of all known CVEs

Summary

IBM Db2 versions 11.5.0 through 11.5.9 and 12.1.0 through 12.1.4 is vulnerable to a denial of service. The flaw occurs when a specially crafted query is run against range partitioned tables.

Risk Assessment

An attacker able to submit queries to the database could cause Db2 service unavailability, disrupting applications that depend on the database.

Recommendation

Update IBM Db2 to a version beyond 11.5.9 or 12.1.4 that contains the fix, and restrict the ability to run arbitrary queries by untrusted users.

Other vulnerabilities in IBM Db2

See all
Original NVD description (English source)

IBM Db2 11.5.0 through 11.5.9, and 12.1.0 through 12.1.4 is vulnerable to a denial of service when a specially crafted query is run with range partitioned tables.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS