CVE Catalog

CVE-2026-58180

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.66%

50th percentile - higher than 50% of all known CVEs

Summary

The Apache Traffic Server txn_box plugin overflows the stack from attacker-controlled input. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Risk Assessment

Stack overflow can lead to crashes or potential code execution, potentially exposing the server to attacks.

Recommendation

It is recommended to upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 to remediate the vulnerability.

Other vulnerabilities in Apache Traffic Server

See all
Original NVD description (English source)

The Apache Traffic Server txn_box plugin overflows the stack from attacker-controlled input. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS