CVE Catalog

CVE-2026-58158

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.58%

46th percentile - higher than 46% of all known CVEs

Summary

Apache Traffic Server mishandles PROXY protocol input, truncating ports and overflowing the stack. Affects versions from 8.0.0 through 8.1.11, 9.0.0 through 9.2.14, and 10.0.0 through 10.1.3.

Risk Assessment

An attacker could exploit this to cause a stack overflow, potentially leading to a crash or arbitrary code execution. Immediate upgrade is recommended.

Recommendation

Upgrade Apache Traffic Server to version 9.2.15 or 10.1.4, which fix the issue.

Other vulnerabilities in Apache Traffic Server

See all
Original NVD description (English source)

Apache Traffic Server mishandles PROXY protocol input, truncating ports and overflowing the stack. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS