CVE Catalog

CVE-2026-57200

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.88%

59th percentile - higher than 59% of all known CVEs

Summary

In Asterisk prior to 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3, an authenticated attacker with read-only ARI permissions may, under certain conditions, perform write operations via REST-over-WebSocket. The authorization bypass enables arbitrary module path loading and conditional remote code execution.

Risk Assessment

An attacker with valid read-only credentials can gain code execution capability on the Asterisk server. The Asterisk HTTP server must be enabled and reachable, though it binds only to 127.0.0.1 by default.

Recommendation

Upgrade Asterisk to 20.20.1, 21.12.3, 22.10.1, 23.4.1 or Certified Asterisk 22.8-cert3. Restrict access to the HTTP interface and apply least privilege to ARI accounts.

Other vulnerabilities in Asterisk

See all
Original NVD description (English source)

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3, an authenticated attacker with read-only permissions for the `Asterisk REST Interface (ARI)` may, under certain conditions, execute write operations through `REST-over-WebSocket`. The authorization bypass permits `arbitrary module path` loading and conditional remote code execution. The Asterisk HTTP web server must be enabled and reachable, and the attacker must already have valid `read-only ARI credentials`. HTTP is disabled by default and binds only to 127.0.0.1 by default even when enabled. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS