CVE-2026-55598
CriticalCVSS 9.1Summary
PinePods before 0.9.0 allows an authenticated user to subscribe to an attacker-controlled RSS feed whose enclosure URL is stored without host/IP validation. The server performs GET/HEAD requests to internal services, enabling service enumeration, data disclosure, and cloud metadata credential theft.
Risk Assessment
A low-privilege user can reach internal network resources and sensitive data, including cloud metadata credentials.
Recommendation
Update PinePods to version 0.9.0 or later and consider disabling self-service signup and server-side downloads.
Related vulnerabilities
- CVE-2026-78403Critical
Stack-based buffer overflow and missing authorization in Thales Sentinel Keys Server on Windows. The server does not check the length of the first field in an HTTP request, allowing an attacker to send a crafted request and potentially achieve remote code execution as NT AUTHORITY\SYSTEM.
- CVE-2026-61850Critical
Kargo versions from 0.6.0 until 1.8.14, 1.9.9, and 1.10.8 contain two authorization flaws in the project-scoped RBAC API. An authenticated user with delegated permission to manage a Project's Roles or ServiceAccounts can confer permissions exceeding their own, enabling escalation to Project-administrator access.
- CVE-2026-61620Critical
HoneySQL turns Clojure data structures into SQL. From 2.0.0 until 2.7.1392, applications passing user input into the DSL via keyword or symbol can produce SQL strings vulnerable to SQL injection because some formatters do not apply the suspicious-character check to entity names.
- CVE-2026-116241Critical
pgAdmin 4 before 9.19 contains a bypass of the CVE-2026-17566 fix in the Import/Export Data tool. Improper validation of a backslash inside a double-quoted identifier hides a closing parenthesis and executes a TO PROGRAM clause via psql on the pgAdmin host with the OS account privileges.
- CVE-2026-90888Critical
The LeadSnap WordPress plugin in versions up to 1.25 contains an unauthenticated PHP Object Injection vulnerability.
- CVE-2026-39738Critical
The FunnelKit Automations WordPress plugin in versions up to 3.8.6.1 contains an unauthenticated PHP Object Injection vulnerability.
- CVE-2026-39732Critical
The Transliterator WordPress plugin in versions up to 2.5.13 contains an unauthenticated SQL Injection vulnerability.
- CVE-2026-119526Critical
The ThemeREX Royal Event WordPress theme in versions up to 2.0 contains a deserialization of untrusted data vulnerability allowing object injection.
- CVE-2026-116852Critical
The Widget Options WordPress plugin in versions up to 4.2.5 contains an author-level Remote Code Execution (RCE) vulnerability.
- CVE-2026-116386Critical
The SMS Alert Order Notifications WordPress plugin in versions up to 4.0.2 contains an unauthenticated privilege escalation vulnerability.
Original NVD description (English source)
PinePods is a complete, self-hosted podcast management system written in Rust. Prior to 0.9.0, an authenticated user can subscribe to an attacker-controlled RSS feed through `POST /api/data/add_podcast` in `rust-api/src/handlers/podcasts.rs`. `get_podcast_values` and `add_episodes` in `rust-api/src/database.rs` parse the feed with `feed-rs` and store the `<enclosure url>` verbatim in `Episodes.episodeurl` without destination host/IP validation. `POST /api/data/download_podcast` invokes `spawn_download_podcast_episode` and `download_episode_and_wait()` in `rust-api/src/services/tasks.rs`, which sends a `reqwest` GET to the stored URL and saves and records the response in `DownloadedEpisodes` for later retrieval. The `estimate_duration_from_audio_url_async()` path in `rust-api/src/database.rs` also sends an unvalidated HEAD during feed add/refresh. Default redirect following permits an initially external enclosure URL to redirect to an internal target. A low-privilege user can make server-side GET/HEAD requests to reachable loopback, private-network and cloud metadata services and read downloaded internal responses, enabling internal-service enumeration, confidential-data disclosure and possible metadata credential theft. Episode downloading requires server downloads to be enabled, which is the default; self-service signup is supported. This issue is fixed in version 0.9.0.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

