CVE Catalog

CVE-2026-54891

LowCVSS 3.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.14%

3th percentile - higher than 3% of all known CVEs

Summary

A vulnerability in the SSL library of Erlang/OTP involves improper enforcement of message integrity during transmission. A network-positioned attacker can inject unauthenticated plaintext into a TLS client during the handshake, which is later treated as authenticated server data by the application. The issue affects the tls_gen_connection module and impacts OTP versions from 17.0 to 27.3.4.14, from 28.0 to 28.5.0.3, and from 29.0 to 29.0.3.

Risk Assessment

The risk is that an attacker can inject fake data into the client application, potentially manipulating application logic or misleading users. The attack does not allow reading client responses or taking over the connection, but it can be used for targeted disruption or social engineering attacks.

Recommendation

It is recommended to immediately upgrade Erlang/OTP to a patched version: OTP 27.3.4.14 or later, OTP 28.5.0.3 or later, or OTP 29.0.3 or later. Also verify that the used ssl library versions are not affected and apply appropriate patches.

Other vulnerabilities in Erlang/OTP ssl

Original NVD description (English source)

Improper Enforcement of Message Integrity During Transmission in a Communication Channel vulnerability in Erlang/OTP ssl (tls_gen_connection module) allows a network-positioned attacker to inject unauthenticated plaintext that the TLS client application later treats as authenticated server data. The function tls_gen_connection:handle_protocol_record/3 rejects APPLICATION_DATA records that arrive in pre-handshake states when the TLS endpoint acts as a server, but does not apply the same check when the endpoint acts as a client. A network-positioned attacker can send plaintext APPLICATION_DATA records to the client during the handshake. The records are buffered and, once the handshake completes successfully, delivered to the application as if they were authenticated post-handshake data. The attacker cannot observe the client's response or steer the connection, so the impact is limited to blind injection of unauthenticated bytes. The injection window is wider for TLS versions prior to TLS 1.3 than for TLS 1.3. This vulnerability is associated with program file lib/ssl/src/tls_gen_connection.erl. TLS 1.3 is affected starting with OTP 22.0, when TLS 1.3 support was added. This issue affects OTP from OTP 17.0 before OTP 27.3.4.14, from OTP 28.0 before OTP 28.5.0.3, and from OTP 29.0 before OTP 29.0.3, corresponding to ssl from 5.3.4 before 11.2.12.10, from 11.3 before 11.6.0.3, and from 11.7 before 11.7.3. Whether OTP before OTP 17.0, corresponding to ssl before 5.3.4, is affected is unknown.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS