CVE Catalog

CVE-2026-54453

HighCVSS 7.2
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.44%

38th percentile - higher than 38% of all known CVEs

Summary

In OpenCATS prior to version 0.10.0, the Professional License configuration feature in SettingsUI accepts administrator-controlled license key input that is reconstructed into a PHP define() statement in config.php without safe escaping. Because the application includes config.php, crafted input can alter the file's PHP syntax and cause persistent arbitrary PHP execution with the web server process privileges.

Risk Assessment

An authenticated administrator with Settings module access can execute arbitrary PHP code, leading to reading, modifying or deleting application data and exposing candidate, company and user account information. This requires config.php to be writable.

Recommendation

Update OpenCATS to version 0.10.0 or later and restrict Settings module access and config.php write permissions to the minimum necessary.

Other vulnerabilities in OpenCATS

See all
Original NVD description (English source)

OpenCATS is an open-source applicant tracking system and recruitment CRM for staffing agencies and hiring teams. Prior to version 0.10.0, the Professional License configuration feature in `SettingsUI` (`manageProfessional`) accepts administrator-controlled license key input that is reconstructed into a PHP `define()` statement in `config.php` without safe escaping. Because the application includes `config.php`, crafted input can alter the file's PHP syntax and cause persistent arbitrary PHP execution with the web server process privileges. An authenticated administrator must have Settings module access and permission to update Professional License configuration, and `config.php` must be writable for this write-based path. Successful exploitation can read, modify or delete application data, expose candidate, contact, company, job order and user account information, alter the installation or configuration, and provide a foothold for further attacks. Unauthenticated exploitation and exploitation without Settings access are not established. This issue is fixed in version 0.10.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS