CVE Catalog

CVE-2026-54162

MediumCVSS 4.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.25%

16th percentile - higher than 16% of all known CVEs

Summary

In Ember before 1.4.2, interactive TUI row formatters pass Caddy access-log fields, especially the request URI, through fitCellLeft without neutralizing terminal escape or control sequences. An unauthenticated client can place ANSI, OSC, or CSI bytes in an HTTP request that, after decoding, reach os.Stdout and are interpreted by the operator's terminal.

Risk Assessment

Monitoring-dashboard spoofing, clipboard hijacking via OSC 52, and window-title spoofing are possible; consequences depend on the terminal emulator and usually require further operator action.

Recommendation

Update Ember to version 1.4.2 or later. Until then, avoid viewing the Logs tab in untrusted environments or use --json/--once modes.

Related vulnerabilities

Original NVD description (English source)

Ember is a real-time terminal dashboard for Caddy servers with FrankenPHP support. Prior to 1.4.2, interactive TUI row formatters pass Caddy access-log fields, particularly the request URI, through the `fitCellLeft` render helper without neutralizing terminal escape or control sequences. An unauthenticated remote client can place ANSI, OSC, or CSI control bytes in an ordinary HTTP request target. Caddy JSON-escapes those bytes, `ParseLogLine` decodes them back into raw controls, and the formatters concatenate them into `View()` output reaching `os.Stdout`. When the operator views the default `Logs` tab, the terminal interprets these sequences, allowing monitoring-dashboard spoofing, clipboard hijacking through `OSC 52`, and window-title spoofing through `OSC 0/2`. This works even with a loopback-only log listener because the input arrives through normal Caddy access logs. `Certificates` and `Routes` share secondary unneutralized render sinks. The `--json`, `--once`, and daemon `--expose` modes are unaffected because they do not render an interactive terminal. Consequences depend on the terminal emulator and usually require further operator action to escalate; this is not general-purpose remote code execution. This issue is fixed in version 1.4.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS