CVE Catalog

CVE-2026-53720

MediumCVSS 5.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.13%

3th percentile - higher than 3% of all known CVEs

Summary

pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap.

Risk Assessment

This could lead to memory corruption, potentially resulting in application crashes or arbitrary code execution if an attacker can control the buffer size.

Recommendation

Update pymonocypher to version 4.0.2.8 or later. Ensure that calls to argon2i_32 adhere to the API contract and provide sufficiently large buffers.

Related vulnerabilities

Original NVD description (English source)

pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap. This issue has been patched in version 4.0.2.8.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS