CVE-2026-44673
HighCVSS 7.5Exploitation Probability (EPSS)
Elevated risk50th percentile - higher than 50% of all known CVEs
Summary
In libyang library prior to SO 5.2.15, an integer overflow in lyb_read_string() in src/parser_lyb.c leads to a heap buffer overflow when parsing a maliciously crafted LYB binary blob. An attacker who can supply LYB data to any libyang consumer (NETCONF server, sysrepo, etc.) can trigger a crash or potential heap corruption.
Risk Assessment
The risk for the organization includes potential remote code execution or service crashes in network services using libyang, which could lead to infrastructure downtime and data integrity compromise.
Recommendation
It is recommended to immediately upgrade libyang to version SO 5.2.15 or later, which contains the fix for this vulnerability. Additionally, restrict LYB data input to trusted sources only.
Other vulnerabilities in libyang
See all- CVE-2026-115327Medium
libyang through 6.4.13 contains an uninitialized pointer free vulnerability in lydxml_env_netconf_rpc() in src/parser_xml.c when parsing NETCONF rpc action envelopes. Peers with a NETCONF session can send an action element containing non-whitespace text via lyd_parse_op() to crash servers like netopeer2 or corrupt the heap.
- CVE-2026-41401Medium
libyang before 5.4.3 contains a heap use-after-free write vulnerability in lyd_parser_set_data_flags that incorrectly updates metadata list pointers when freeing non-head default metadata entries. Attackers can trigger it by submitting crafted YANG XML documents with specific metadata attributes to applications parsing untrusted XML data.
Original NVD description (English source)
libyang is a YANG data modeling language library. Prior to SO 5.2.15, lyb_read_string() in src/parser_lyb.c contains an integer overflow that results in a heap buffer overflow when parsing a maliciously crafted LYB binary blob. An attacker who can supply LYB data to any libyang consumer (NETCONF server, sysrepo, etc.) can trigger a crash or potential heap corruption. This vulnerability is fixed in SO 5.2.15.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

