CVE Catalog

CVE-2026-42180

MediumCVSS 6.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

8th percentile - higher than 8% of all known CVEs

Summary

In Lemmy prior to version 0.19.18, an authenticated low-privileged user can create a link post via POST /api/v3/post. The backend asynchronously sends a Webmention to the attacker-controlled target, and the code path does not reject loopback, private, or link-local destinations.

Risk Assessment

A normal user can trigger server-side HTTP requests toward internal services (SSRF). This may lead to disclosure of or interaction with internal infrastructure.

Recommendation

Update Lemmy to version 0.19.18 or later. Until updated, consider restricting outbound HTTP requests from the Lemmy server to trusted address ranges.

Other vulnerabilities in Lemmy

See all
Original NVD description (English source)

Lemmy is a link aggregator and forum for the fediverse. Prior to version 0.19.18, Lemmy allows an authenticated low-privileged user to create a link post through POST /api/v3/post. When a post is created in a public community, the backend asynchronously sends a Webmention to the attacker-controlled link target. The submitted URL is checked for syntax and scheme, but the audited code path does not reject loopback, private, or link-local destinations before the Webmention request is issued. This lets a normal user trigger server-side HTTP requests toward internal services. This issue has been patched in version 0.19.18.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS